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6 ThinManager Interface 

6.1 Opening ThinManager  
ThinManager is used for the configuration of Thin Clients in the ACP thin client environment. 

ThinManager can be started using any of the traditional Windows methods, based on the administrator's 
preference: 

 Run from the Start Menu, Start > Programs > \Automation Control Products > 
ThinManager or Run Start > Programs > \ ACP > ThinManager depending on the 
installation folder. 

 Run from the Run line, Start > Run > C:\Program Files\Automation Control 
Products\ThinManager\ThinManager.exe (default path). 

 Run from a command prompt, C:\Program Files\Automation Control 
Products\ThinManager\ThinManager.exe (default path).  

 Run from a shortcut on the desktop. 

 Run from a ThinManager icon in the system tray, if this option is selected in View > Options 
from the menu bar.  

 Run from Windows Explorer.  

Note: ThinManager can be run on a terminal with full privileges if the user is an administrator or a 
member of the ThinManager Administrator’s group. See ThinManager Server Configuration wizard for 
details on ThinManager User Groups. 
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6.2 ThinManager Graphic User Interface 

 
ACP ThinManager Graphic User Interface 

The ThinManager administrative interface provides "at-a-glance management". The groups and 
terminals are displayed in the tree pane. The configuration data is displayed in the detail panel. Color-
coded icons in the tree pane show the on-line status of terminals. 

The sections of the ThinManager interface include: 

 A Title Bar  with the standard Windows Minimize/Maximize/Close shortcut icons. 

 A Menu Bar  with commands.  

 A Tree Pane  with an expandable/collapsible tree showing the Terminals, Display Servers, 
Display Clients, TermSecure Users on the ThinManager Server. Terminals that are on-line 
have a green monitor icon, while stopped or rebooting terminals have a red monitor icon.  

 A tabbed Details Pane  with information about settings and configurations. The blue group 
icon denotes a property that was obtained from the group. The details pane is tabbed for 
organization. The tabs that are shown depend on the tree item that is highlighted. 

 A Status Bar  that shows advice and tips.  

 The Communication Indicator  shows green when ThinManager is talking to a 
ThinManager Server. ThinManager will wait until this communication is finished before 
processing additional requests. 
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6.3 Tree Pane 
The tree pane shows the members of the ACP Thin Client Network in an expandable tree. 

 
ACP ThinManager with Tree 

The Tree has five branches.  

 Terminals – This lists terminal groups and terminals. Terminal groups can be expanded to show 
member terminals and terminals can be expanded to show assigned display clients.  

 Display Servers – This lists the display server types that can be used when configuring display 
clients. 

 VCenter Servers - This allows ThinManager to list and manage VMWare VCenter servers. 

 Display Clients – This lists the display client types that can be added to a terminal configuration. 
They can be expanded to show the members of each display client type. 

 TermSecure Users – This lists configured TermSecure Users and any created groups of 
TermSecure users. 
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6.4 Icons 

6.4.1 Tree Icons 
Several of the menu tools and other features are dependent on what icon is highlighted in the tree.  

The tree is divided into five branches, Terminals, Display Servers, VCenter Servers, Display Clients 
and TermSecure Users.  

 
Five Tree Branches 

Each of the branches, shown as a blue icon, can be expanded. 
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Expanded Tree Showing Icon Variety 

Terminal Groups can be expanded to show the subgroups and terminals that are members of the group. 

Terminals can be expanded to show the display clients assigned to it. 

Display Clients can be expanded to show the members that are assigned to it. 

TermSecure User Group can be expanded to show the TermSecure Users that are members of the 
group. 

Each of the branches of the tree can be expanded. 
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6.4.1.1 ThinManager Server Icons 

 

ThinManager Server Icons 

ThinManager can connect to several ThinManager Servers, but only one ThinManager Server tree can be 
displayed at a time. The tree shows the local ThinManager Server by default. Other ThinManager Servers 
can be added to the ThinManager Server drop-down box by selecting Edit > Add ThinManager Server 
from the menu bar. 

A Green ThinManager Server icon represents a ThinManager Server that has an active communication 
link with the program. These can be collapsed or expanded to show the Group and Terminal icons that 
nest under the ThinManager Server icons. 

A Red ThinManager Server icon represents a ThinManager Server that is not communicating with the 
program. Right clicking on a red ThinManager icon and selecting Reconnect will reinitiate 
communications to the ThinManager Server. 

6.4.1.2 Terminal Icons 

The Terminals branch can be expanded to show Terminal Groups and terminals. 

 

Group and Terminal Icons 

A Group is represented by an icon of two monitors with a blue screen. Subgroups can be nested under 
Groups. 

A Terminal is represented by an icon of a single monitor. 

 A Red terminal screen indicates that the Terminal is off or not communicating with the 
ThinManager Server. 

 A Purple terminal screen indicates that the Terminal is loading the firmware during the boot 
process. 
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 A Yellow terminal screen indicates that the Terminal has loaded firmware, received its 
configuration and is in the process of establishing a monitor connection to the ThinManager 
Server. 

 A Green terminal screen indicates that the Terminal is on and communicating with the 
ThinManager Server. 

 A Terminal with a Head icon indicates that a TermSecure User is logged onto the terminal. The 
TermSecure User name will be displayed in parentheses. 

 A Terminal with a Lock or a locked group icon means that that terminal or group is being 
modified and cannot be changed by another user. If the Group or Terminal remains locked after 
its configuration wizard is closed, it can be unlocked by using Edit > Unlock from the menu bar.  

 A Terminal with a Red X indicated that an administrator has disabled the terminal. 

Note: The purple and yellow screen will not be visible before the terminal has connected the first time and 
is defined in ThinManager. 
The purple and yellow screens are only visible during a reboot and not after a restart, as a restarted 
terminal does not reload firmware. 

The Terminal icon can be expanded to show the assignment of the terminal. 

 

Terminal Assigned to Individual Terminal Servers 

A terminal that is using individual terminal servers may expand to show a terminal server icon with three 
connection states. 

 A green lightning bolt indicates an active connection to the terminal server. 

 A yellow lightning bolt indicates an active connection that is cascaded in the background while 
using Instant Failover. 

 A red lightning bolt indicates an inactive connection to the terminal server. 
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Terminal using Display Clients 

A terminal that is using Display Clients can be expanded to show the status of the Display Clients. The 
Display Clients can be expanded to show the status of the Display Client members. 

If a Group or Terminal is disabled using the Tools > Disable function, it will be displayed with a red X 
over the terminal icon. An entire ThinManager Server or an entire Group can be disabled, but the 
ThinManager Server icon and the Group icon will not show an X, just the terminal icons. 

 

Disabled Terminal Icons 

A Red terminal screen with a Red X indicates that the Terminal is disabled and is either turned off or 
rebooted and waiting to be enabled. 

A Green terminal screen with a Red X indicates that the disabling has been applied to the terminal that 
is turned on. The terminal has a disabling screen and is waiting for enabling. 

If a Group or Terminal is disabled using the Tools > Disable function, it will be displayed with a red X 
over the terminal icon. An entire ThinManager Server or an entire Group can be disabled, but the 
ThinManager Server icon and the Group icon will not show an X, just the terminal icons. 

Once a terminal is disabled, a disabling screen will appear on the terminal until the terminal has been 
enabled. 
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Disabling Screen 

If a terminal is active when it is disabled, it will display the Disable Screen with a message indicating the 
disabled status in the upper left corner. 

 

Disabled Terminal 

If a terminal is booted when disabled, the boot process will be halted until the terminal is enabled. 

See Disable Terminals for details. 
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6.4.1.3 Display Servers Branch 

The Display Servers section of the tree is where display sources are defined and configured. These 
definitions will be used when defining a Display Client. Examples of Display Servers are Terminal Servers 
and IP Cameras. 

 
Display Servers Tree Branch 

6.4.1.4 Terminal Server Connection Icons 

The Display Servers Terminal Servers branch can be expanded to show the Terminal Servers that are 
configured. The Terminal Servers can be expanded to show the member terminal servers. The member 
terminal servers can be expanded to show the terminals connected to them. The monitor screen color 
and the lightning bolt color indicate the terminal’s status on the Terminal Server. 

 

Terminal Server Connection Icons 

The monitor screen color indicates the ThinManager Server connection status. The lightning bolt color 
indicates the Terminal Server connection status. 

 A Red monitor screen indicates that the terminal is off or unable to communicate to the 
ThinManager Server. 

 A Green monitor screen indicates that the terminal is on and able to communicate to the 
ThinManager Server. 

 A Red lightning bolt represents a lack of active connection to the terminal server. 

 A Green lightning bolt represents a connection to the terminal server with an active session. 

 A Yellow lightning bolt represents a connection to the terminal server with a session that is the 
backup session in Instant Failover mode. 
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6.4.1.5 VCenter Server Icons 

 

VCenter Server Tree Icons 

6.4.1.6 Display Clients Branch 

The Display Clients section of the tree is where the usage of a Display Server is defined. Display Clients 
are added to the terminal configuration. Examples of Display Clients are Terminal Services Display 
Clients, IP Camera Display Clients, Terminal Shadow Display Clients, and Workstation Display Clients. 

 

Display Client Tree Branch 

6.4.1.7 TermSecure User Branch 

The TermSecure Users branch can be expanded. 
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TermSecure User Tree 

The TermSecure User branch expands to show TermSecure User Groups.  

A Two-headed icon represents a TermSecure User Group. This can be expanded to show member 
TermSecure Users. 

A Single-headed icon represents a TermSecure User. This can be expanded to show any Display 
Clients that are assigned to the TermSecure User. 

A Single-head with Terminal icon represents a TermSecure User that is logged in on a terminal. The 
terminal name is shown in parentheses. This can be expanded to show any Display Clients that are 
assigned to the TermSecure User. 

A TermSecure User that is not active or logged into a terminal server will show the normal Display Client 
icon. 

A TermSecure User that is active and logged into a terminal will show an icon of the TermSecure User 
head with the Display Client 

6.5 Details Pane 
The Details Pane has tabs to provide additional information. Highlighting different items in the tree will 
display a different set of tabs and the corresponding set of information. 

6.5.1 ThinManager Server Detail Tabs 
Highlighting the green ThinManager Server will show: 

 Configuration - These are the configuration parameters set in the ThinManager Server 
Configuration Wizard and include the Event Messaging summary.  

 Licenses - This displays the installed licenses, the quantity used and the quantity available. 
ThinManager lists all the license files and identifies whether that are valid or invalid. This tab 
will display licenses for both ThinManager Servers if the pair is auto-synchronized. 

 Versions - This displays the version numbers of ThinManager, the firmware, and the 
TermCap database. 

 Synchronization – This will show the synchronization status of the ThinManager Server. 
See Automatic Synchronization for details. 

 Event Log - This displays events for the ThinManager Server. The events and duration are 
configurable in the ThinManager Server Configuration wizard. See Event Selection Page for 
details. 

 Report – This will display the selected report for the ThinManager Server. See Reports for 
details. 
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 IP Assignment – This will display the IP address, MAC Address, and Terminal name of PXE 
boot clients when the ThinManager PXE Server is configured to assign IP addresses to 
terminals. See PXE Server Configuration Wizard for details. 

 

ThinManager Server Tabs 

6.5.2 Terminal Group Detail Tabs 
Highlighting a Group will show: 

 Configuration - These are the configuration parameters set in the Group Configuration 
Wizard and include Terminal Server assignments, video settings, and monitoring settings. 
See Terminal Group Configuration Wizard for details. 

 Modules - This lists the assigned modules and parameters for the Group. See Modules for 
details. 

 Schedule – This will display any events scheduled for the Group. See Terminal Schedule for 
details. 

 Properties - This is blank for a Group. 

 Event Log - This is blank for a Group. 

 Shadow – This is blank for a Group 

 Report – This will display the selected report for the group. See Reports for details. 
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Group Tabs – Modules 

6.5.3 Terminal Detail Tabs 
Highlighting a Terminal will show: 

 Configuration - These are the configuration parameters set in the Terminal Configuration 
Wizard and include Terminal Server assignments, video settings, and monitoring settings. 
See Terminal Configuration Wizard for details. 

 Modules - This lists the assigned modules and parameters for the Terminal. See Modules for 
details. 

 Schedule – This will display any events scheduled for the terminal. See Terminal Schedule 
for details. 

 Properties - This shows the IP address, firmware version, make and model, CPU, memory 
usage, Terminal Up Time, CPU load, and BootROM version of the Terminal.  

 Event Log - This shows the terminal events and terminal configuration events for that 
terminal, if event logging is enabled in the ThinManager Configuration Wizard. See Event 
Selection Page for details. 

 Shadow – This tab shows what the terminal is displaying on its monitor. Administrators can 
interact with the session while ThinManager Power Users can view the session but not 
control it. See ThinManager Security Groups for details. 

 Report – This will display the selected report for the terminal. See Reports for details. 
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Terminal Tabs – Shadow 

6.5.4 Terminal Server Detail Tabs 
Highlighting the blue Terminal Server branch will show: 

 Status - This shows the status of the communication connection between the local 
ThinManager Server and the defined Terminal Servers and ThinManager Servers. This 
shows whether the local ThinManager Server is able to retrieve the updated resource 
information used in determining the SmartSession Server Ranking. See Terminal Server 
Name Page for details. 

 Summary - This will report information on the terminal servers like available memory, uptime, 
CPU utilization, and operating system. 

 Event Log - This shows the terminal events and terminal configuration events for that 
terminal server, if event logging is enabled in the ThinManager Configuration Wizard. See 
Event Selection Page for details. 

The Connection Status of the Terminal Servers may have different messages: 

 OK indicates a good connection. 

 WTSAPI32.dll connection failed occurs when the terminal server is off or unreachable. 

 The RPC Server is unavailable occurs when the terminal server is off or unreachable. 

 No login information supplied indicates that the Terminal Server didn’t have a username 
and password added in the Terminal Server List Wizard.  
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 User specified does not have permission to connect indicates that the Terminal Server 
had an invalid username and password added in the Terminal Server List Wizard. 

 

Terminal Servers Tabs – Status 

Highlighting an individual Terminal Server will show: 

 Configuration - This shows the installed Client Communication Protocols and the 
SmartSession settings for the Terminal Server. See Terminal Server Capabilities Page for 
details. 

 Properties – This tab displays the server resource data like total memory, free memory, 
uptime, and CPU speed.  

 Schedule – This will display any events scheduled for the Group. See Terminal Server 
Schedule for details. 

 Users - This tab displays information from the Terminal Services Manager. It shows users 
that are logged into the Terminal Server. Right clicking on a user will show options that allow 
the session to be Reset (logged off), Disconnected, or have a message sent to it.  

 Sessions - This tab displays information from the Terminal Services Manager. It shows users 
that are logged into the Terminal Server. Right clicking on a user will show options that allow 
the session to be Reset (logged off), Disconnected, or have a message sent to it.  

 Processes - This tab displays information from the Terminal Services Manager. It shows the 
processes running on the Terminal Server and can have them sorted by Session ID (users) 
or Process Name. Right clicking on a process will give the option to kill the process.  

 Graph – This tab will display the CPU usage and memory usage of the terminal server as a 
graph. This graph can contain one hour of historical data.  
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 Event Log - This shows the terminal events and terminal configuration events for that 
terminal, if event logging is enabled in the ThinManager Configuration Wizard. Event 
Selection Page for details. 

 Connect – This tab will open a connection from ThinManager to the terminal server. This 
session allows administrators to manage the terminal server from within ThinManager. See 
Connect Options for details. 

 Report – This will display the selected report for the terminal server. See Reports for details. 

 

Terminal Server Tabs - Users 

6.5.5 Modifying a Terminal 
Modifying a terminal allows you to reconfigure the terminal or change group settings such as touch 
screen usage, video resolution, or to assign it to a terminal server.  

To modify a terminal open the Terminal Configuration Wizard or the Terminal Properties by either: 

 Highlighting the terminal in the ThinManager tree pane by clicking on the terminal name or 
icon and select Edit > Modify from the ThinManager menu bar. 

 Right-clicking on the terminal icon in the ThinManager tree pane and select Modify. 

 Double-clicking on a terminal icon in the ThinManager tree pane. 

This will launch the Terminal Configuration Wizard, allowing changes to be made. 

Note: The terminal will need to be restarted for the changes to take effect.  
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6.5.6 Deleting a Terminal 
A terminal can be deleted from the ThinManager by: 

 Highlighting the terminal in the ThinManager tree pane and selecting Edit > Delete from the 
ThinManager menu bar  

 Right-clicking a terminal icon in the tree pane of ThinManager and selecting Delete 
Terminal.  

6.5.7 Restarting a Terminal 
A restart will reload any changes to a terminal configuration or firmware without a cycling of power. 

A terminal or group can be restarted by:  

 Selecting Tools>Restart Terminal from the ThinManager menu bar. This will restart all the 
terminals on the server if the server is highlighted. If a group is highlighted, all members of 
the group will be highlighted. If a terminal is highlighted, the terminal is restarted. 

 Right-clicking a ThinManager Server icon in the tree pane of ThinManager and selecting 
Restart Terminals. This will reboot all the terminals in the tree. 

 Right-clicking a group icon in the tree pane of ThinManager and selecting Restart 
Terminals. This will reboot all the terminals in the group. 

 Right- clicking a terminal icon in the tree pane of ThinManager and selecting Restart 
Terminal. This will restart only the highlighted terminal. 

6.5.8 Rebooting a Terminal 
A reboot will cycle power to the terminal, reloading firmware and configuration. 

A terminal or group can be rebooted by:  

 Selecting Tools>Reboot Terminals from the ThinManager menu bar. This will reboot all the 
terminals on the server if the server is highlighted. If a group is highlighted, all members of 
the group will be highlighted. If a terminal is highlighted, the terminal is rebooted. 

6.5.9 Renaming a Terminal 
Terminals can be renamed by: 

 Highlighting the Terminal and selecting Edit > Rename. 

 Right-clicking the Terminal and selecting Rename. 

Note: Renaming a terminal can be accomplished the same way that files or directories are renamed in 
Windows Explorer. Single click twice on the terminal name; this will draw a box around the name and 
highlight it. Type the new terminal name. 
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Renaming a Terminal 

The terminal name should be less than 15 characters because of limitations on the terminal server. 

Tip on single clicking  twice: Click once to highlight the name, move the mouse slightly and click again. 
This will prevent Windows from confusing the two single clicks with a double click. 

 


